What’s Vulnerable › Vulnerabilities
CVE-2021-39371
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-23 · updated 2026-06-17
- Weakness: CWE-611
Description
An XML external entity (XXE) injection in PyWPS before 4.4.5 allows an attacker to view files on the application server filesystem by assigning a path to the entity. OWSLib 0.24.1 may also be affected.
Affected products
- Debian Linux: 9.0
- geopython OWSLib: 0.24.1
- OSGeo Pywps: before 4.4.5 — fixed in 4.4.5
How to fix
Upgrade to a fixed version: OSGeo Pywps 4.4.5. Check the vendor advisory for mitigations.
References
- https://github.com/geopython/OWSLib/issues/790
- https://github.com/geopython/pywps/pull/616
- https://lists.debian.org/debian-lts-announce/2021/09/msg00001.html
- https://github.com/geopython/OWSLib/issues/790
- https://github.com/geopython/pywps/pull/616
- https://lists.debian.org/debian-lts-announce/2021/09/msg00001.html
Get alerted when CVE-2021-39371 or the next vulnerability affects your stack