What’s Vulnerable › Vulnerabilities
CVE-2021-3948
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-18 · updated 2026-06-17
- Weakness: CWE-276
Description
An incorrect default permissions vulnerability was found in the mig-controller. Due to an incorrect cluster namespaces handling an attacker may be able to migrate a malicious workload to the target cluster, impacting confidentiality, integrity, and availability of the services located on that cluster.
Affected products
- Konveyor Mig-Controller: before 1.5.2; from 1.6.0 before 1.6.3 — fixed in 1.5.2, 1.6.3
- RedHat Migration Toolkit: 1.0, 1.5, 1.6
How to fix
Upgrade to a fixed version: Konveyor Mig-Controller 1.5.2, 1.6.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2022017
- https://bugzilla.redhat.com/show_bug.cgi?id=2022017
Get alerted when CVE-2021-3948 or the next vulnerability affects your stack