What’s Vulnerable › Vulnerabilities
CVE-2021-3950: Cross-site Scripting (XSS) - Stored in django-helpdesk/django-helpdesk
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-19 · updated 2026-06-17
- Weakness: CWE-79
Description
django-helpdesk is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- django-helpdesk/django-helpdesk: before 0.3.1 — fixed in 0.3.1
How to fix
Upgrade to a fixed version: django-helpdesk/django-helpdesk 0.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/django-helpdesk/django-helpdesk/commit/04483bdac3b5196737516398b5ce0383875a5c60
- https://huntr.dev/bounties/4d7a5fdd-b2de-467a-ade0-3f2fb386638e
- https://github.com/django-helpdesk/django-helpdesk/commit/04483bdac3b5196737516398b5ce0383875a5c60
- https://huntr.dev/bounties/4d7a5fdd-b2de-467a-ade0-3f2fb386638e
Get alerted when CVE-2021-3950 or the next vulnerability affects your stack