What’s Vulnerable › Vulnerabilities
CVE-2021-3961: Cross-site Scripting (XSS) - Stored in snipe/snipe-it
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-19 · updated 2026-06-17
- Weakness: CWE-79
Description
snipe-it is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- grokability snipe-it: before 5.3.2 — fixed in 5.3.2
How to fix
Upgrade to a fixed version: grokability snipe-it 5.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/snipe/snipe-it/commit/7ce5993f5ae9d713a0955c2fd8e2dff7a7ce886e
- https://huntr.dev/bounties/5987aed5-6613-4937-8a3e-d48009b7da10
- https://github.com/snipe/snipe-it/commit/7ce5993f5ae9d713a0955c2fd8e2dff7a7ce886e
- https://huntr.dev/bounties/5987aed5-6613-4937-8a3e-d48009b7da10
Get alerted when CVE-2021-3961 or the next vulnerability affects your stack