What’s Vulnerable › Vulnerabilities
CVE-2021-3963: Cross-Site Request Forgery (CSRF) in kevinpapst/kimai2
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-19 · updated 2026-06-17
- Weakness: CWE-352
Description
kimai2 is vulnerable to Cross-Site Request Forgery (CSRF)
Affected products
- kevinpapst/kimai2: before 1.16.2 — fixed in 1.16.2
How to fix
Upgrade to a fixed version: kevinpapst/kimai2 1.16.2. Check the vendor advisory for mitigations.
References
- https://github.com/kevinpapst/kimai2/commit/95796ab2560ad93f44068a88f0fad758c2053514
- https://huntr.dev/bounties/3abf308b-7dbd-4864-b1a9-5c45b876def8
- https://github.com/kevinpapst/kimai2/commit/95796ab2560ad93f44068a88f0fad758c2053514
- https://huntr.dev/bounties/3abf308b-7dbd-4864-b1a9-5c45b876def8
Get alerted when CVE-2021-3963 or the next vulnerability affects your stack