What’s Vulnerable › Vulnerabilities
CVE-2021-3968: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-19 · updated 2026-10-08
- Weakness: CWE-122
Description
vim is vulnerable to Heap-based Buffer Overflow
Affected products
- Fedoraproject Fedora: 34, 35
- vim/vim: from 8.2.3430 before 8.2.3610 — fixed in 8.2.3610
How to fix
Upgrade to a fixed version: vim/vim 8.2.3610. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/a062006b9de0b2947ab5fb376c6e67ef92a8cd69
- https://huntr.dev/bounties/00d62924-a7b4-4a61-ba29-acab2eaa1528
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FNXY7T5OORA7UJIMGSJBGHFMU6UZWS6P/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IH2LS2DXBTYOCWGAKFMBF3HTWWXPBEFL/
- https://security.gentoo.org/glsa/202208-32
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/a062006b9de0b2947ab5fb376c6e67ef92a8cd69
- https://huntr.dev/bounties/00d62924-a7b4-4a61-ba29-acab2eaa1528
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FNXY7T5OORA7UJIMGSJBGHFMU6UZWS6P/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IH2LS2DXBTYOCWGAKFMBF3HTWWXPBEFL/
- https://security.gentoo.org/glsa/202208-32
Get alerted when CVE-2021-3968 or the next vulnerability affects your stack