What’s Vulnerable › Vulnerabilities
CVE-2021-3973: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-19 · updated 2026-10-08
- Weakness: CWE-122
Description
vim is vulnerable to Heap-based Buffer Overflow
Affected products
- Debian Linux: 9.0
- Fedoraproject Fedora: 34, 35
- vim/vim: before 8.2.3611 — fixed in 8.2.3611
How to fix
Upgrade to a fixed version: vim/vim 8.2.3611. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/615ddd5342b50a6878a907062aa471740bd9a847
- https://huntr.dev/bounties/ce6e8609-77c6-4e17-b9fc-a2e5abed052e
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FNXY7T5OORA7UJIMGSJBGHFMU6UZWS6P/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IH2LS2DXBTYOCWGAKFMBF3HTWWXPBEFL/
- https://security.gentoo.org/glsa/202208-32
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/615ddd5342b50a6878a907062aa471740bd9a847
- https://huntr.dev/bounties/ce6e8609-77c6-4e17-b9fc-a2e5abed052e
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FNXY7T5OORA7UJIMGSJBGHFMU6UZWS6P/
Get alerted when CVE-2021-3973 or the next vulnerability affects your stack