What’s Vulnerable › Vulnerabilities
CVE-2021-3974: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-19 · updated 2026-10-08
- Weakness: CWE-416
Description
vim is vulnerable to Use After Free
Affected products
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 34, 35
- vim/vim: before 8.2.3612 — fixed in 8.2.3612
How to fix
Upgrade to a fixed version: vim/vim 8.2.3612. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/64066b9acd9f8cffdf4840f797748f938a13f2d6
- https://huntr.dev/bounties/e402cb2c-8ec4-4828-a692-c95f8e0de6d4
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FNXY7T5OORA7UJIMGSJBGHFMU6UZWS6P/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IH2LS2DXBTYOCWGAKFMBF3HTWWXPBEFL/
- https://security.gentoo.org/glsa/202208-32
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/64066b9acd9f8cffdf4840f797748f938a13f2d6
- https://huntr.dev/bounties/e402cb2c-8ec4-4828-a692-c95f8e0de6d4
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
Get alerted when CVE-2021-3974 or the next vulnerability affects your stack