What’s Vulnerable › Vulnerabilities
CVE-2021-3978: Improper Preservation of Permissions in github.com/cloudflare/cfrpki/cmd/octorpki
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-29 · updated 2026-06-17
- Weakness: CWE-269
Description
When copying files with rsync, octorpki uses the "-a" flag 0, which forces rsync to copy binaries with the suid bit set as root. Since the provided service definition defaults to root ( https://github.com/cloudflare/cfrpki/blob/master/package/octorpki.service ) this could allow for a vector, when combined with another vulnerability that causes octorpki to process a malicious TAL file, for a local privilege escalation.
Affected products
- Cloudflare octorpki: before 1.4.2 — fixed in 1.4.2
How to fix
Upgrade to a fixed version: Cloudflare octorpki 1.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-3978 or the next vulnerability affects your stack