What’s Vulnerable › Vulnerabilities
CVE-2021-3983: Cross-site Scripting (XSS) - Stored in kevinpapst/kimai2
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-01 · updated 2026-06-17
- Weakness: CWE-79
Description
kimai2 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- Kimai2 Project Kimai2: before 1.16.3 — fixed in 1.16.3
How to fix
Upgrade to a fixed version: Kimai2 Project Kimai2 1.16.3. Check the vendor advisory for mitigations.
References
- https://github.com/kevinpapst/kimai2/commit/89bfa82c61da0d3639e4038e689e25467baac8a0
- https://huntr.dev/bounties/c96f3480-dccf-4cc2-99a4-d2b3a7462413
- https://github.com/kevinpapst/kimai2/commit/89bfa82c61da0d3639e4038e689e25467baac8a0
- https://huntr.dev/bounties/c96f3480-dccf-4cc2-99a4-d2b3a7462413
Get alerted when CVE-2021-3983 or the next vulnerability affects your stack