What’s Vulnerable › Vulnerabilities
CVE-2021-3984: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-01 · updated 2026-06-17
- Weakness: CWE-122
Description
vim is vulnerable to Heap-based Buffer Overflow
Affected products
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 34
- vim/vim: before 8.2.3625 — fixed in 8.2.3625
How to fix
Upgrade to a fixed version: vim/vim 8.2.3625. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/2de9b7c7c8791da8853a9a7ca9c467867465b655
- https://huntr.dev/bounties/b114b5a2-18e2-49f0-b350-15994d71426a
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FNXY7T5OORA7UJIMGSJBGHFMU6UZWS6P/
- https://security.gentoo.org/glsa/202208-32
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/2de9b7c7c8791da8853a9a7ca9c467867465b655
- https://huntr.dev/bounties/b114b5a2-18e2-49f0-b350-15994d71426a
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
Get alerted when CVE-2021-3984 or the next vulnerability affects your stack