What’s Vulnerable › Vulnerabilities
CVE-2021-3985: Cross-site Scripting (XSS) - Stored in kevinpapst/kimai2
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-01 · updated 2026-06-17
- Weakness: CWE-79
Description
kimai2 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- Kimai2: before 1.16.3 — fixed in 1.16.3
How to fix
Upgrade to a fixed version: Kimai2 1.16.3. Check the vendor advisory for mitigations.
References
- https://github.com/kevinpapst/kimai2/commit/76e09447c85e762882126b49626a4fe4d93fe8b5
- https://huntr.dev/bounties/89d6c3de-efbd-4354-8cc8-46e999e4c5a4
- https://github.com/kevinpapst/kimai2/commit/76e09447c85e762882126b49626a4fe4d93fe8b5
- https://huntr.dev/bounties/89d6c3de-efbd-4354-8cc8-46e999e4c5a4
Get alerted when CVE-2021-3985 or the next vulnerability affects your stack