What’s Vulnerable › Vulnerabilities
CVE-2021-39859: Use After Free Adobe Acrobat Pro DC [HB-21-0339]
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-06 · updated 2026-06-17
- Weakness: CWE-416
Description
Acrobat Reader DC versions 2021.005.20060 (and earlier), 2020.004.30006 (and earlier) and 2017.011.30199 (and earlier) are affected by a Use After Free vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Acrobat for Edge: from 17.011.30180 before 17.011.30202; from 20.001.30005 before 20.004.30015 — fixed in 17.011.30202, 20.004.30015
- Adobe Acrobat DC: from 15.007.20033 through 21.005.20060; from 15.007.20033 through 21.005.20058
- Adobe Acrobat Reader: from 17.011.30180 before 17.011.30202; from 20.001.30005 before 20.004.30015 — fixed in 17.011.30202, 20.004.30015
- Adobe Acrobat Reader: from 15.007.20033 through 21.005.20060; from 15.007.20033 through 21.005.20058
How to fix
Upgrade to a fixed version: Adobe Acrobat for Edge 17.011.30202, 20.004.30015; Adobe Acrobat Reader 17.011.30202, 20.004.30015. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/acrobat/apsb21-55.html
- https://helpx.adobe.com/security/products/acrobat/apsb21-55.html
Get alerted when CVE-2021-39859 or the next vulnerability affects your stack