What’s Vulnerable › Vulnerabilities
CVE-2021-39870
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-05 · updated 2026-06-17
Description
In all versions of GitLab CE/EE since version 11.11, an instance that has the setting to disable Repo by URL import enabled is bypassed by an attacker making a crafted API call.
Affected products
- GitLab: from 11.11.0 before 14.1.7; from 14.2.0 before 14.2.5; from 14.3.0 before 14.3.1 — fixed in 14.1.7, 14.2.5, 14.3.1
How to fix
Upgrade to a fixed version: GitLab 14.1.7, 14.2.5, 14.3.1. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39870.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/29748
- https://hackerone.com/reports/630263
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39870.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/29748
- https://hackerone.com/reports/630263
Get alerted when CVE-2021-39870 or the next vulnerability affects your stack