What’s Vulnerable › Vulnerabilities
CVE-2021-39872
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-05 · updated 2026-06-17
- Weakness: CWE-287
Description
In all versions of GitLab CE/EE since version 14.1, an improper access control vulnerability allows users with expired password to still access GitLab through git and API through access tokens acquired before password expiration.
Affected products
- GitLab: from 14.1.0 before 14.1.7; from 14.2.0 before 14.2.5; 4.3.0 — fixed in 14.1.7, 14.2.5
How to fix
Upgrade to a fixed version: GitLab 14.1.7, 14.2.5. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39872.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/337954
- https://hackerone.com/reports/1285226
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39872.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/337954
- https://hackerone.com/reports/1285226
Get alerted when CVE-2021-39872 or the next vulnerability affects your stack