What’s Vulnerable › Vulnerabilities
CVE-2021-39873
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-04 · updated 2026-06-17
Description
In all versions of GitLab CE/EE, there exists a content spoofing vulnerability which may be leveraged by attackers to trick users into visiting a malicious website by spoofing the content in an error response.
Affected products
- GitLab: from 1.0.0 before 14.1.7; from 14.2.0 before 14.2.5; 4.3.0 — fixed in 14.1.7, 14.2.5
How to fix
Upgrade to a fixed version: GitLab 14.1.7, 14.2.5. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39873.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/27241
- https://hackerone.com/reports/504961
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39873.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/27241
- https://hackerone.com/reports/504961
Get alerted when CVE-2021-39873 or the next vulnerability affects your stack