What’s Vulnerable › Vulnerabilities
CVE-2021-39877
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-04 · updated 2026-06-17
- Weakness: CWE-400
Description
A vulnerability was discovered in GitLab starting with version 12.2 that allows an attacker to cause uncontrolled resource consumption with a specially crafted file.
Affected products
- GitLab: from 12.2.0 before 14.1.7; from 14.2 before 14.2.5; from 14.3 before 14.3.1 — fixed in 14.1.7, 14.2.5, 14.3.1
How to fix
Upgrade to a fixed version: GitLab 14.1.7, 14.2.5, 14.3.1. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39877.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/300095
- https://hackerone.com/reports/1077021
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39877.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/300095
- https://hackerone.com/reports/1077021
Get alerted when CVE-2021-39877 or the next vulnerability affects your stack