What’s Vulnerable › Vulnerabilities

CVE-2021-39880

Description

A Denial Of Service vulnerability in the apollo_upload_server Ruby gem in GitLab CE/EE all versions starting from 11.9 before 14.0.9, all versions starting from 14.1 before 14.1.4, and all versions starting from 14.2 before 14.2.2 allows an attacker to deny access to all users via specially crafted requests to the apollo_upload_server middleware.

Affected products

How to fix

Upgrade to a fixed version: GitLab 14.0.9, 14.1.4, 14.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-39880 or the next vulnerability affects your stack