What’s Vulnerable › Vulnerabilities
CVE-2021-39881
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-05 · updated 2026-06-17
Description
In all versions of GitLab CE/EE since version 7.7, the application may let a malicious user create an OAuth client application with arbitrary scope names which may allow the malicious user to trick unsuspecting users to authorize the malicious client application using the spoofed scope name and description.
Affected products
- GitLab: from 7.7.0 before 14.1.7; from 14.2.0 before 14.2.5; from 14.3.0 before 14.3.1 — fixed in 14.1.7, 14.2.5, 14.3.1
How to fix
Upgrade to a fixed version: GitLab 14.1.7, 14.2.5, 14.3.1. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39881.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/26695
- https://hackerone.com/reports/494530
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39881.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/26695
- https://hackerone.com/reports/494530
Get alerted when CVE-2021-39881 or the next vulnerability affects your stack