What’s Vulnerable › Vulnerabilities

CVE-2021-39885

Description

A Stored XSS in merge request creation page in all versions of Gitlab EE starting from 13.7 before 14.1.7, all versions starting from 14.2 before 14.2.5, and all versions starting from 14.3 before 14.3.1 allows an attacker to execute arbitrary JavaScript code on the victim's behalf via malicious approval rule names

Affected products

How to fix

Upgrade to a fixed version: GitLab 14.1.7, 14.2.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-39885 or the next vulnerability affects your stack