What’s Vulnerable › Vulnerabilities
CVE-2021-39890
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-06 · updated 2026-06-17
- Weakness: CWE-287
Description
It was possible to bypass 2FA for LDAP users and access some specific pages with Basic Authentication in GitLab 14.1.1 and above.
Affected products
- GitLab: from 14.1.1 before 14.1.7; from 14.2.0 before 14.2.5; 14.3.0, 14.3.1 — fixed in 14.1.7, 14.2.5
How to fix
Upgrade to a fixed version: GitLab 14.1.7, 14.2.5. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39890.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/341522
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39890.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/341522
Get alerted when CVE-2021-39890 or the next vulnerability affects your stack