What’s Vulnerable › Vulnerabilities
CVE-2021-39892
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-18 · updated 2026-06-17
Description
In all versions of GitLab CE/EE since version 12.0, a lower privileged user can import users from projects that they don't have a maintainer role on and disclose email addresses of those users.
Affected products
- GitLab: from 12.0 before 14.1.7; from 14.2 before 14.2.5; 14.3.0 — fixed in 14.1.7, 14.2.5
How to fix
Upgrade to a fixed version: GitLab 14.1.7, 14.2.5. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39892.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/28440
- https://hackerone.com/reports/542539
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39892.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/28440
- https://hackerone.com/reports/542539
Get alerted when CVE-2021-39892 or the next vulnerability affects your stack