What’s Vulnerable › Vulnerabilities
CVE-2021-39899
- Severity: medium (CVSS 4.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-04 · updated 2026-06-17
- Weakness: CWE-640
Description
In all versions of GitLab CE/EE, an attacker with physical access to a user’s machine may brute force the user’s password via the change password function. There is a rate limit in place, but the attack may still be conducted by stealing the session id from the physical compromise of the account and splitting the attack over several IP addresses and passing in the compromised session value from these various locations.
Affected products
- GitLab: from 1.0.0 before 14.1.7; from 14.2 before 14.2.5; from 14.3 before 14.3.1 — fixed in 14.1.7, 14.2.5, 14.3.1
How to fix
Upgrade to a fixed version: GitLab 14.1.7, 14.2.5, 14.3.1. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39899.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/339154
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39899.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/339154
Get alerted when CVE-2021-39899 or the next vulnerability affects your stack