What’s Vulnerable › Vulnerabilities

CVE-2021-39908

Description

In all versions of GitLab CE/EE starting from 0.8.0 before 14.2.6, all versions starting from 14.3 before 14.3.4, and all versions starting from 14.4 before 14.4.1 certain Unicode characters can be abused to commit malicious code into projects without being noticed in merge request or source code viewer UI.

Affected products

How to fix

Upgrade to a fixed version: GitLab 14.2.6, 14.3.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-39908 or the next vulnerability affects your stack