What’s Vulnerable › Vulnerabilities
CVE-2021-39914
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-04 · updated 2026-06-17
- Weakness: CWE-400
Description
A regular expression denial of service issue in GitLab versions 8.13 to 14.2.5, 14.3.0 to 14.3.3 and 14.4.0 could cause excessive usage of resources when a specially crafted username was used when provisioning a new user
Affected products
- GitLab: from 8.13.0 before 14.2.6; from 14.3.0 before 14.3.4; 14.4.0 — fixed in 14.2.6, 14.3.4
How to fix
Upgrade to a fixed version: GitLab 14.2.6, 14.3.4. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39914.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/289948
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39914.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/289948
Get alerted when CVE-2021-39914 or the next vulnerability affects your stack