What’s Vulnerable › Vulnerabilities
CVE-2021-39917
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-13 · updated 2026-06-17
- Weakness: CWE-697
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 12.9 before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2. A regular expression related to quick actions features was susceptible to catastrophic backtracking that could cause a DOS attack.
Affected products
- GitLab: from 12.9.0 before 14.3.6; from 14.4.0 before 14.4.4; from 14.5.0 before 14.5.2 — fixed in 14.3.6, 14.4.4, 14.5.2
How to fix
Upgrade to a fixed version: GitLab 14.3.6, 14.4.4, 14.5.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39917.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/338486
- https://hackerone.com/reports/1277918
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39917.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/338486
- https://hackerone.com/reports/1277918
Get alerted when CVE-2021-39917 or the next vulnerability affects your stack