What’s Vulnerable › Vulnerabilities
CVE-2021-3992: Improper Access Control in kevinpapst/kimai2
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-01 · updated 2026-06-17
- Weakness: CWE-284
Description
kimai2 is vulnerable to Improper Access Control
Affected products
- Kimai2 Project Kimai2: before 1.16.2 — fixed in 1.16.2
How to fix
Upgrade to a fixed version: Kimai2 Project Kimai2 1.16.2. Check the vendor advisory for mitigations.
References
- https://github.com/kevinpapst/kimai2/commit/ff9acab0fc81f0e9490462739ef15fe4ab028ea5
- https://huntr.dev/bounties/a0c438fb-c8e1-40cf-acc6-c8a532b80b93
- https://github.com/kevinpapst/kimai2/commit/ff9acab0fc81f0e9490462739ef15fe4ab028ea5
- https://huntr.dev/bounties/a0c438fb-c8e1-40cf-acc6-c8a532b80b93
Get alerted when CVE-2021-3992 or the next vulnerability affects your stack