What’s Vulnerable › Vulnerabilities
CVE-2021-39937
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-13 · updated 2026-06-17
- Weakness: CWE-269
Description
A collision in access memoization logic in all versions of GitLab CE/EE before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2, leads to potential elevated privileges in groups and projects under rare circumstances
Affected products
- GitLab: before 14.3.6; from 14.4.0 before 14.4.4; from 14.5.0 before 14.5.2 — fixed in 14.3.6, 14.4.4, 14.5.2
How to fix
Upgrade to a fixed version: GitLab 14.3.6, 14.4.4, 14.5.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39937.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/336802
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39937.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/336802
Get alerted when CVE-2021-39937 or the next vulnerability affects your stack