What’s Vulnerable › Vulnerabilities
CVE-2021-3994: Cross-site Scripting (XSS) - Stored in django-helpdesk/django-helpdesk
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-01 · updated 2026-06-17
- Weakness: CWE-79
Description
django-helpdesk is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- django-helpdesk/django-helpdesk: before 0.3.2 — fixed in 0.3.2
How to fix
Upgrade to a fixed version: django-helpdesk/django-helpdesk 0.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/django-helpdesk/django-helpdesk/commit/a22eb0673fe0b7784f99c6b5fd343b64a6700f06
- https://huntr.dev/bounties/be7f211d-4bfd-44fd-91e8-682329906fbd
- https://github.com/django-helpdesk/django-helpdesk/commit/a22eb0673fe0b7784f99c6b5fd343b64a6700f06
- https://huntr.dev/bounties/be7f211d-4bfd-44fd-91e8-682329906fbd
Get alerted when CVE-2021-3994 or the next vulnerability affects your stack