What’s Vulnerable › Vulnerabilities
CVE-2021-4005: Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-04 · updated 2026-06-17
- Weakness: CWE-352
Description
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
Affected products
- firefly-iii/firefly-iii: before 5.6.5 — fixed in 5.6.5
How to fix
Upgrade to a fixed version: firefly-iii/firefly-iii 5.6.5. Check the vendor advisory for mitigations.
References
- https://github.com/firefly-iii/firefly-iii/commit/03a1601bf343181df9f405dd2109aec483cb7053
- https://huntr.dev/bounties/bf4ef581-325a-492d-a710-14fcb53f00ff
- https://github.com/firefly-iii/firefly-iii/commit/03a1601bf343181df9f405dd2109aec483cb7053
- https://huntr.dev/bounties/bf4ef581-325a-492d-a710-14fcb53f00ff
Get alerted when CVE-2021-4005 or the next vulnerability affects your stack