What’s Vulnerable › Vulnerabilities
CVE-2021-40083
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-25 · updated 2026-06-17
- Weakness: CWE-617
Description
Knot Resolver before 5.3.2 is prone to an assertion failure, triggerable by a remote attacker in an edge case (NSEC3 with too many iterations used for a positive wildcard proof).
Affected products
- CZ.NIC knot-resolver: before 5.3.2 — fixed in 5.3.2
How to fix
Upgrade to a fixed version: CZ.NIC knot-resolver 5.3.2. Check the vendor advisory for mitigations.
References
- https://gitlab.nic.cz/knot/knot-resolver/-/merge_requests/1169
- https://gitlab.nic.cz/knot/knot-resolver/-/merge_requests/1169
Get alerted when CVE-2021-40083 or the next vulnerability affects your stack