What’s Vulnerable › Vulnerabilities
CVE-2021-40096
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-07 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability in integration configuration in SquaredUp for SCOM 5.2.1.6654 allows remote attackers to inject arbitrary web script or HTML via modification of the authorisationUrl in some integration configurations.
Affected products
- Squaredup: before 5.3.1 — fixed in 5.3.1
How to fix
Upgrade to a fixed version: Squaredup 5.3.1. Check the vendor advisory for mitigations.
References
- https://support.squaredup.com
- https://support.squaredup.com/hc/en-us/articles/4410656396817-CVE-2021-40096-Stored-cross-site-scripting-provider-configuration-
- https://support.squaredup.com
- https://support.squaredup.com/hc/en-us/articles/4410656396817-CVE-2021-40096-Stored-cross-site-scripting-provider-configuration-
Get alerted when CVE-2021-40096 or the next vulnerability affects your stack