What’s Vulnerable › Vulnerabilities
CVE-2021-40110: Apache James IMAP vulnerable to a ReDoS
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-04 · updated 2026-06-17
Description
In Apache James, using Jazzer fuzzer, we identified that an IMAP user can craft IMAP LIST commands to orchestrate a Denial Of Service using a vulnerable Regular expression. This affected Apache James prior to 3.6.1 We recommend upgrading to Apache James 3.6.1 or higher , which enforce the use of RE2J regular expression engine to execute regex in linear time without back-tracking.
Affected products
- Apache Software Foundation Apache James: before 3.6.1 — fixed in 3.6.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache James 3.6.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/04/2
- https://www.openwall.com/lists/oss-security/2022/01/04/2
- http://www.openwall.com/lists/oss-security/2022/01/04/2
- https://www.openwall.com/lists/oss-security/2022/01/04/2
Get alerted when CVE-2021-40110 or the next vulnerability affects your stack