What’s Vulnerable › Vulnerabilities
CVE-2021-40111: Apache James IMAP parsing Denial Of Service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-04 · updated 2026-06-17
- Weakness: CWE-835
Description
In Apache James, while fuzzing with Jazzer the IMAP parsing stack, we discover that crafted APPEND and STATUS IMAP command could be used to trigger infinite loops resulting in expensive CPU computations and OutOfMemory exceptions. This can be used for a Denial Of Service attack. The IMAP user needs to be authenticated to exploit this vulnerability. This affected Apache James prior to version 3.6.1. This vulnerability had been patched in Apache James 3.6.1 and higher. We recommend the upgrade.
Affected products
- Apache Software Foundation Apache James: before 3.6.1 — fixed in 3.6.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache James 3.6.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/04/3
- https://www.openwall.com/lists/oss-security/2022/01/04/3
- http://www.openwall.com/lists/oss-security/2022/01/04/3
- https://www.openwall.com/lists/oss-security/2022/01/04/3
Get alerted when CVE-2021-40111 or the next vulnerability affects your stack