What’s Vulnerable › Vulnerabilities
CVE-2021-40114: Multiple Cisco Products Snort Memory Leak Denial of Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-27 · updated 2026-08-11
- Weakness: CWE-770
Description
Multiple Cisco products are affected by a vulnerability in the way the Snort detection engine processes ICMP traffic that could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition on an affected device. The vulnerability is due to improper memory resource management while the Snort detection engine is processing ICMP packets. An attacker could exploit this vulnerability by sending a series of ICMP packets through an affected device. A successful exploit could allow the attacker to exhaust resources on the affected device, causing the device to reload.
Affected products
- Cisco Firepower Management Center: 2.9.14.0, 2.9.15, 2.9.16, 2.9.17
- Cisco Firepower Threat Defense Software: before 6.4.0.12; from 6.5.0 before 6.6.3; from 6.7.0 before 6.7.0.2 — fixed in 6.4.0.12, 6.6.3, 6.7.0.2
- Cisco Unified Threat Defense: from 16.12 before 16.12.6; from 17.3 before 17.3.4a; from 17.4 before 17.4.2 — fixed in 16.12.6, 17.3.4a, 17.4.2
- Snort: from 2.0.0 before 2.9.18 — fixed in 2.9.18
How to fix
Upgrade to a fixed version: Cisco Firepower Threat Defense Software 6.4.0.12, 6.6.3, 6.7.0.2; Cisco Unified Threat Defense 16.12.6, 17.3.4a, 17.4.2; Snort 2.9.18. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2023/02/msg00011.html
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-snort-dos-s2R7W9UU
- https://www.debian.org/security/2023/dsa-5354
- https://lists.debian.org/debian-lts-announce/2023/02/msg00011.html
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-snort-dos-s2R7W9UU
- https://www.debian.org/security/2023/dsa-5354
Get alerted when CVE-2021-40114 or the next vulnerability affects your stack