What’s Vulnerable › Vulnerabilities
CVE-2021-40117: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software SSL/TLS Denial of Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-27 · updated 2026-08-11
- Weakness: CWE-119
Description
A vulnerability in SSL/TLS message handler for Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition on an affected device. This vulnerability exists because incoming SSL/TLS packets are not properly processed. An attacker could exploit this vulnerability by sending a crafted SSL/TLS packet to an affected device. A successful exploit could allow the attacker to cause the affected device to reload, resulting in a DoS condition.
Affected products
- Cisco Adaptive Security Appliance: before 9.8.4.40 — fixed in 9.8.4.40
- Cisco ASA Software: from 9.9.0 before 9.12.4.26; from 9.13.0 before 9.14.3.9; from 9.15.0 before 9.15.1.17; from 9.16.0 before 9.16.2.3 — fixed in 9.12.4.26, 9.14.3.9, 9.15.1.17, 9.16.2.3
- Cisco Asa 5505 Firmware: 009.009(002.085), 009.014(002.106)
- Cisco Asa 5512-X Firmware: 009.009(002.085), 009.014(002.106)
- Cisco Asa 5515-X Firmware: 009.009(002.085), 009.014(002.106)
- Cisco Asa 5525-X Firmware: 009.009(002.085), 009.014(002.106)
- Cisco Asa 5545-X Firmware: 009.009(002.085), 009.014(002.106)
- Cisco Asa 5555-X Firmware: 009.009(002.085), 009.014(002.106)
- Cisco Asa 5580 Firmware: 009.009(002.085), 009.014(002.106)
- Cisco Asa 5585-X Firmware: 009.009(002.085), 009.014(002.106)
- Cisco Firepower Threat Defense Software: before 6.2.3.17; from 6.3.0 before 6.4.0.13; from 6.5.0 before 6.6.5; from 6.7.0 before 6.7.0.3; from 7.0.0 before 7.0.1 — fixed in 6.2.3.17, 6.4.0.13, 6.6.5, 6.7.0.3, 7.0.1
How to fix
Upgrade to a fixed version: Cisco Adaptive Security Appliance 9.8.4.40; Cisco ASA Software 9.12.4.26, 9.14.3.9, 9.15.1.17, 9.16.2.3; Cisco Firepower Threat Defense Software 6.2.3.17, 6.4.0.13, 6.6.5, 6.7.0.3. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asaftd-dos-4ygzLKU9
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asaftd-dos-4ygzLKU9
Get alerted when CVE-2021-40117 or the next vulnerability affects your stack