What’s Vulnerable › Vulnerabilities
CVE-2021-40125: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software IKEv2 Site-to-Site VPN Denial of Service Vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-27 · updated 2026-08-11
- Weakness: CWE-416
Description
A vulnerability in the Internet Key Exchange Version 2 (IKEv2) implementation of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an authenticated, remote attacker to trigger a denial of service (DoS) condition on an affected device. This vulnerability is due to improper control of a resource. An attacker with the ability to spoof a trusted IKEv2 site-to-site VPN peer and in possession of valid IKEv2 credentials for that peer could exploit this vulnerability by sending malformed, authenticated IKEv2 messages to an affected device. A successful exploit could allow the attacker to trigger a reload of the device.
Affected products
- Cisco ASA Software: from 9.8.0 before 9.8.4.40; from 9.9.0 before 9.12.4.30; from 9.14.0 before 9.14.3.9; from 9.15.0 before 9.15.1.17; from 9.16.0 before 9.16.2 — fixed in 9.12.4.30, 9.14.3.9, 9.15.1.17, 9.16.2, 9.8.4.40
- Cisco Asa 5505 Firmware: 009.016(001.025)
- Cisco Asa 5512-X Firmware: 009.016(001.025)
- Cisco Asa 5515-X Firmware: 009.016(001.025)
- Cisco Asa 5525-X Firmware: 009.016(001.025)
- Cisco Asa 5545-X Firmware: 009.016(001.025)
- Cisco Asa 5555-X Firmware: 009.016(001.025)
- Cisco Asa 5580 Firmware: 009.016(001.025)
- Cisco Asa 5585-X Firmware: 009.016(001.025)
- Cisco Firepower Threat Defense Software: before 6.4.0.13; from 6.6.0 before 6.6.5; from 6.7.0 before 6.7.0.3; from 7.0.0 before 7.0.1 — fixed in 6.4.0.13, 6.6.5, 6.7.0.3, 7.0.1
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.12.4.30, 9.14.3.9, 9.15.1.17, 9.16.2; Cisco Firepower Threat Defense Software 6.4.0.13, 6.6.5, 6.7.0.3, 7.0.1. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asaftd-ikev2-dos-g4cmrr7C
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asaftd-ikev2-dos-g4cmrr7C
Get alerted when CVE-2021-40125 or the next vulnerability affects your stack