What’s Vulnerable › Vulnerabilities
CVE-2021-40131: Cisco Common Services Platform Collector Stored Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-19 · updated 2026-06-17
- Weakness: CWE-87
Description
A vulnerability in the web-based management interface of Cisco Common Services Platform Collector (CSPC) could allow an authenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the interface. This vulnerability is due to insufficient validation of user-supplied input that is processed by the web-based management interface. An attacker could exploit this vulnerability by adding malicious code to the configuration by using the web-based management interface. A successful exploit could allow the attacker to execute arbitrary code in the context of the interface or access sensitive, browser-based information.
Affected products
- Cisco Common Services Platform Collector Software: before 2.9.1.1 — fixed in 2.9.1.1
How to fix
Upgrade to a fixed version: Cisco Common Services Platform Collector Software 2.9.1.1. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-CSPC-XSS-KjrNbM3p
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-CSPC-XSS-KjrNbM3p
Get alerted when CVE-2021-40131 or the next vulnerability affects your stack