What’s Vulnerable › Vulnerabilities
CVE-2021-4015: Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-01 · updated 2026-06-17
- Weakness: CWE-352
Description
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
Affected products
- firefly-iii/firefly-iii: before 5.6.4 — fixed in 5.6.4
How to fix
Upgrade to a fixed version: firefly-iii/firefly-iii 5.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/firefly-iii/firefly-iii/commit/518b4ba5a7a56760902758ae0a2c6a392c2f4d37
- https://huntr.dev/bounties/b698d445-602d-4701-961c-dffe6d3009b1
- https://github.com/firefly-iii/firefly-iii/commit/518b4ba5a7a56760902758ae0a2c6a392c2f4d37
- https://huntr.dev/bounties/b698d445-602d-4701-961c-dffe6d3009b1
Get alerted when CVE-2021-4015 or the next vulnerability affects your stack