What’s Vulnerable › Vulnerabilities
CVE-2021-4018: Cross-site Scripting (XSS) - Stored in snipe/snipe-it
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-01 · updated 2026-06-17
- Weakness: CWE-79
Description
snipe-it is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- grokability snipe-it: before 5.3.3 — fixed in 5.3.3
How to fix
Upgrade to a fixed version: grokability snipe-it 5.3.3. Check the vendor advisory for mitigations.
References
- https://github.com/snipe/snipe-it/commit/ff81e6d5366c2cfb15618793ad919ae4cbb3ac57
- https://huntr.dev/bounties/c14395f6-bf0d-4b06-b4d1-b509d8a99b54
- https://github.com/snipe/snipe-it/commit/ff81e6d5366c2cfb15618793ad919ae4cbb3ac57
- https://huntr.dev/bounties/c14395f6-bf0d-4b06-b4d1-b509d8a99b54
Get alerted when CVE-2021-4018 or the next vulnerability affects your stack