What’s Vulnerable › Vulnerabilities
CVE-2021-4019: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-01 · updated 2026-06-17
- Weakness: CWE-122
Description
vim is vulnerable to Heap-based Buffer Overflow
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Fedoraproject Fedora: 34, 35
- Neovim: before 0.7.0 — fixed in 0.7.0
- vim/vim: before 8.2.3669 — fixed in 8.2.3669
How to fix
Upgrade to a fixed version: Neovim 0.7.0; vim/vim 8.2.3669. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/bd228fd097b41a798f90944b5d1245eddd484142
- https://huntr.dev/bounties/d8798584-a6c9-4619-b18f-001b9a6fca92
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DRPAI5JVZLI7WHWSBR6NWAPBQAYUQREW/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FNXY7T5OORA7UJIMGSJBGHFMU6UZWS6P/
- https://security.gentoo.org/glsa/202208-32
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/bd228fd097b41a798f90944b5d1245eddd484142
- https://huntr.dev/bounties/d8798584-a6c9-4619-b18f-001b9a6fca92
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
Get alerted when CVE-2021-4019 or the next vulnerability affects your stack