What’s Vulnerable › Vulnerabilities
CVE-2021-40329
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-27 · updated 2026-06-17
Description
The Authentication API in Ping Identity PingFederate before 10.3 mishandles certain aspects of external password management.
Affected products
- Ping Identity PingFederate: before 10.3 — fixed in 10.3
How to fix
Upgrade to a fixed version: Ping Identity PingFederate 10.3. Check the vendor advisory for mitigations.
References
- https://docs.pingidentity.com/bundle/pingfederate-103/page/cou1615333347158.html
- https://docs.pingidentity.com/bundle/pingfederate-103/page/cou1615333347158.html
Get alerted when CVE-2021-40329 or the next vulnerability affects your stack