What’s Vulnerable › Vulnerabilities
CVE-2021-4033: Cross-Site Request Forgery (CSRF) in kevinpapst/kimai2
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-09 · updated 2026-06-17
- Weakness: CWE-352
Description
kimai2 is vulnerable to Cross-Site Request Forgery (CSRF)
Affected products
- kevinpapst/kimai2: before 1.16.7 — fixed in 1.16.7
How to fix
Upgrade to a fixed version: kevinpapst/kimai2 1.16.7. Check the vendor advisory for mitigations.
References
- https://github.com/kevinpapst/kimai2/commit/1da26e041df62c10bd8075d78f2db7854d3eee07
- https://huntr.dev/bounties/e05be1f7-d00c-4cfd-9390-ccd9d1c737b7
- https://github.com/kevinpapst/kimai2/commit/1da26e041df62c10bd8075d78f2db7854d3eee07
- https://huntr.dev/bounties/e05be1f7-d00c-4cfd-9390-ccd9d1c737b7
Get alerted when CVE-2021-4033 or the next vulnerability affects your stack