What’s Vulnerable › Vulnerabilities
CVE-2021-40331: Permissions problem in the Apache Ranger Hive Plugin
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-05 · updated 2026-06-17
- Weakness: CWE-732
Description
An Incorrect Permission Assignment for Critical Resource vulnerability was found in the Apache Ranger Hive Plugin. Any user with SELECT privilege on a database can alter the ownership of the table in Hive when Apache Ranger Hive Plugin is enabled This issue affects Apache Ranger Hive Plugin: from 2.0.0 through 2.3.0. Users are recommended to upgrade to version 2.4.0 or later.
Affected products
- Apache Software Foundation Apache Ranger: from 2.0.0 through 2.3.0
References
- https://lists.apache.org/thread/s68yls6cnkdmzn1k4hqt50vs6wjvt2rn
- https://lists.apache.org/thread/s68yls6cnkdmzn1k4hqt50vs6wjvt2rn
Get alerted when CVE-2021-40331 or the next vulnerability affects your stack