What’s Vulnerable › Vulnerabilities
CVE-2021-40369: XSS vulnerability on Denounce plugin
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-24 · updated 2026-06-17
- Weakness: CWE-79
Description
A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki, related to the Denounce plugin, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.0 or later.
Affected products
- Apache Software Foundation Apache JSPWiki: before 2.11.0 — fixed in 2.11.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache JSPWiki 2.11.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/08/03/3
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2021-40369
- https://lists.apache.org/thread/r2j00nrnpjgcmoxvlv3pgfoq9kzrcsfh
- http://www.openwall.com/lists/oss-security/2022/08/03/3
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2021-40369
- https://lists.apache.org/thread/r2j00nrnpjgcmoxvlv3pgfoq9kzrcsfh
Get alerted when CVE-2021-40369 or the next vulnerability affects your stack