What’s Vulnerable › Vulnerabilities
CVE-2021-40377
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-08 · updated 2026-06-17
- Weakness: CWE-79
Description
SmarterTools SmarterMail 16.x before build 7866 has stored XSS. The application fails to sanitize email content, thus allowing one to inject HTML and/or JavaScript into a page that will then be processed and stored by the application.
Affected products
- SmarterTools SmarterMail: from 16.0.6345 before 16.3.7866 — fixed in 16.3.7866
How to fix
Upgrade to a fixed version: SmarterTools SmarterMail 16.3.7866. Check the vendor advisory for mitigations.
References
- https://www.smartertools.com/smartermail/release-notes/current
- https://www.smartertools.com/smartermail/release-notes/current
Get alerted when CVE-2021-40377 or the next vulnerability affects your stack