What’s Vulnerable › Vulnerabilities
CVE-2021-4038: NSM vulnerable to XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross Site Scripting (XSS) vulnerability in McAfee Network Security Manager (NSM) prior to 10.1 Minor 7 allows a remote authenticated administrator to embed a XSS in the administrator interface via specially crafted custom rules containing HTML. NSM did not correctly sanitize custom rule content in all scenarios.
Affected products
- McAfee Network Security Management (NSM): before 10.1.7.48 — fixed in 10.1.7.48
How to fix
Upgrade to a fixed version: McAfee Network Security Management (NSM) 10.1.7.48. Check the vendor advisory for mitigations.
References
- https://kc.mcafee.com/corporate/index?page=content&id=SB10375
- https://kc.mcafee.com/corporate/index?page=content&id=SB10375
Get alerted when CVE-2021-4038 or the next vulnerability affects your stack