What’s Vulnerable › Vulnerabilities
CVE-2021-40516
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-05 · updated 2026-06-17
- Weakness: CWE-125
Description
WeeChat before 3.2.1 allows remote attackers to cause a denial of service (crash) via a crafted WebSocket frame that trigger an out-of-bounds read in plugins/relay/relay-websocket.c in the Relay plugin.
Affected products
- Debian Linux: 10.0
- weechat: from 0.4.1 before 3.2.1 — fixed in 3.2.1
How to fix
Upgrade to a fixed version: weechat 3.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/weechat/weechat/commit/8b1331f98de1714bae15a9ca2e2b393ba49d735b
- https://lists.debian.org/debian-lts-announce/2021/09/msg00018.html
- https://weechat.org/doc/security/
- https://github.com/weechat/weechat/commit/8b1331f98de1714bae15a9ca2e2b393ba49d735b
- https://lists.debian.org/debian-lts-announce/2021/09/msg00018.html
- https://weechat.org/doc/security/
Get alerted when CVE-2021-40516 or the next vulnerability affects your stack