What’s Vulnerable › Vulnerabilities
CVE-2021-40656
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-08 · updated 2026-06-17
- Weakness: CWE-787
Description
libsixel before 1.10 is vulnerable to Buffer Overflow in libsixel/src/quant.c:867.
Affected products
- Libsixel: before 1.10.0 — fixed in 1.10.0
How to fix
Upgrade to a fixed version: Libsixel 1.10.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-40656 or the next vulnerability affects your stack