What’s Vulnerable › Vulnerabilities
CVE-2021-4069: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-06 · updated 2026-06-17
- Weakness: CWE-416
Description
vim is vulnerable to Use After Free
Affected products
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 34, 35
- vim/vim: before 8.2.3741 — fixed in 8.2.3741
How to fix
Upgrade to a fixed version: vim/vim 8.2.3741. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/e031fe90cf2e375ce861ff5e5e281e4ad229ebb9
- https://huntr.dev/bounties/0efd6d23-2259-4081-9ff1-3ade26907d74
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FNXY7T5OORA7UJIMGSJBGHFMU6UZWS6P/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WYB2LLNUFJUKJJ5HYCZ6MV3Z6YX3U5BN/
- https://security.gentoo.org/glsa/202208-32
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/e031fe90cf2e375ce861ff5e5e281e4ad229ebb9
- https://huntr.dev/bounties/0efd6d23-2259-4081-9ff1-3ade26907d74
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
Get alerted when CVE-2021-4069 or the next vulnerability affects your stack